# Can't add Synology NAS

**URL:** <https://forum.remote.it/t/cant-add-synology-nas/877>\
**Category:** Troubleshooting\
**Created:** [July 20, 2023, 4:02pm UTC](https://forum.remote.it/t/cant-add-synology-nas/877 "2023-07-20T16:02:01Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![hdi](https://avatars.discourse-cdn.com/v4/letter/h/3ec8ea/32.png) [@hdi](https://forum.remote.it/u/hdi)\
**Post date:** [July 20, 2023, 4:02pm UTC](https://forum.remote.it/t/cant-add-synology-nas/877/1 "2023-07-20T16:02:01Z")

</div>

Downloaded and installed(manual install) package on my synology DS1821+ no problem.

But when I enter the claim code at [Remote.It](https://app.remote.it/#/add)  
It says “your device could not be found.”

I also see this error poping up at the bottom of the page:

GraphQL: Error: Cannot insert the value NULL into column ‘id’, table ‘yoics.dbo.r3\_Licenses’; column does not allow nulls. INSERT fails.

I have reinstalled a few times to get new claim codes but no luck.

Anyone know what I’m doing wrong?

Edit: I also tried doing the same thing on my Synology DS1819+ with the same result.

---

<div class="post-metadata">

**Author:** ![bstrech](https://yyz2.discourse-cdn.com/flex030/user_avatar/forum.remote.it/bstrech/32/266_2.png) [@bstrech](https://forum.remote.it/u/bstrech)\
**Post date:** [July 20, 2023, 5:05pm UTC](https://forum.remote.it/t/cant-add-synology-nas/877/2 "2023-07-20T17:05:01Z")

</div>

Sorry for the issue. We had a bug in our API which is now resolved.
