Community Forum

One Raspberry Pi overriding another Pi

I have an intermittent issue where one of the Raspberry Pi’s that I use (Pi 2) temporarily overrides another one on my account (Pi 1).

Pi 1 was added to the account long before Pi 2. Later, I created Pi 2 from a backup image of Pi 1, uninstalled, reinstalled it, configured the connections (with a different name for the device) and everything worked fine for several weeks, until about 16 August 2019. For a while on the 16th, attempting to connect via SSH to Pi 1 would actually connect to Pi 2, while HTTP connections to Pi 1 worked normally. The remote IP address for the two Pi’s was even the same for a while. Then the problem resolved itself, for a while.

Today, the problem is back and also affects HTTP connections. This means that I can’t connect to Pi 1 at all as every attempt ends up at Pi 2.

Any advice is welcome.

Never mind, the problem was that Pi 2 has an old installation of weavedconnectd that came to life and still had the settings from Pi 1, so in effect I had weavedconnectd and connectd running on the same Pi, with weavedconnectd on Pi 2 interfering with the connection to weavedconnectd on Pi 1.

Thanks for letting us know you got it sorted out. Having a cloned configuration will cause that sort of problem.

I.m about to have the same issue having just cloned an SD card which already has an instance of on it. What is the correct procedure to assign a new identity to the cloned Pi


If the services have already been registered, you will have a problem if you clone that image. We have several approaches to mass production of device with Please see:

The following approach still requires you to log in on each device but the installation script is not interactive.

Also note that the connectd_register script is now included in the connectd package as of the most recent 2.4.26 release.

Let me know if you have any other questions.

Thanks for prompt reply. Would it be easier to uninstall/reinstall on the cloned device with a new identity?


Assuming you are using the connectd package, you can wipe out the existing configuration on the device by running:

sudo rm /etc/connectd/services/*.conf

1 Like