# Ubuntu 24.04 desktop application not working

**URL:** <https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203>\
**Category:** Desktop\
**Created:** [October 9, 2024, 3:32pm UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203 "2024-10-09T15:32:11Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![pkuppler](https://avatars.discourse-cdn.com/v4/letter/p/ba9def/32.png) [@pkuppler](https://forum.remote.it/u/pkuppler)\
**Post date:** [October 9, 2024, 3:32pm UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203/1 "2024-10-09T15:32:11Z")

</div>

After upgrading to Ubuntu 24.04 the desktop application won’t open anymore.  
I tried a fresh install using the .deb file and apt and it’s still the same.  
In the terminal I get the error:

```auto
[67359:1009/173002.605277:FATAL:credentials.cc(127)] Check failed: . : Permission denied (13)
Trace/breakpoint trap (core dumped)

```

And when I run it with sudo it starts but I only see a blank window and get many error messages in the terminal which are too many to paste here.  
I use wayland and gnome.

---

<div class="post-metadata">

**Author:** ![pkuppler](https://avatars.discourse-cdn.com/v4/letter/p/ba9def/32.png) [@pkuppler](https://forum.remote.it/u/pkuppler)\
**Post date:** [October 9, 2024, 3:39pm UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203/2 "2024-10-09T15:39:58Z")

</div>

Some of the errors I get when running with sudo are:

```auto
[67439:1009/173058.259406:ERROR:bus.cc(407)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")

```

```auto
Authorization required, but no authorization protocol specified

```

```auto
[67610:1009/173058.392291:ERROR:angle_platform_impl.cc(44)] Display.cpp:1052 (initialize): ANGLE Display::initialize error 12289: Could not open the default X display.
ERR: Display.cpp:1052 (initialize): ANGLE Display::initialize error 12289: Could not open the default X display.
[67610:1009/173058.392621:ERROR:gl_display.cc(515)] EGL Driver message (Critical) eglInitialize: Could not open the default X display.
[67610:1009/173058.392751:ERROR:gl_display.cc(786)] eglInitialize OpenGL failed with error EGL_NOT_INITIALIZED, trying next display type

```

and

```auto
[67610:1009/173058.487887:ERROR:angle_platform_impl.cc(44)] Display.cpp:1052 (initialize): ANGLE Display::initialize error 12289: Could not open the default X display.
ERR: Display.cpp:1052 (initialize): ANGLE Display::initialize error 12289: Could not open the default X display.
[67610:1009/173058.488097:ERROR:gl_display.cc(515)] EGL Driver message (Critical) eglInitialize: Could not open the default X display.
[67610:1009/173058.488204:ERROR:gl_display.cc(786)] eglInitialize OpenGLES failed with error EGL_NOT_INITIALIZED
[67610:1009/173058.488310:ERROR:gl_display.cc(820)] Initialization of all EGL display types failed.
[67610:1009/173058.488410:ERROR:gl_ozone_egl.cc(26)] GLDisplayEGL::Initialize failed.
[67610:1009/173058.490990:ERROR:viz_main_impl.cc(196)] Exiting GPU process due to errors during initialization
[67439:1009/173058.557647:ERROR:object_proxy.cc(576)] Failed to call method: org.freedesktop.DBus.NameHasOwner: object_path= /org/freedesktop/DBus: unknown error type: 
Authorization required, but no authorization protocol specified

```

which seem to repeate

---

<div class="post-metadata">

**Author:** ![bstrech](https://yyz2.discourse-cdn.com/flex030/user_avatar/forum.remote.it/bstrech/32/266_2.png) [@bstrech](https://forum.remote.it/u/bstrech)\
**Post date:** [October 9, 2024, 8:28pm UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203/3 "2024-10-09T20:28:41Z")

</div>

Which log are you looking at? What is the path?  
You typically do not start our Desktop app from the command line. Are you talking about the remoteit CLI?

---

<div class="post-metadata">

**Author:** ![pkuppler](https://avatars.discourse-cdn.com/v4/letter/p/ba9def/32.png) [@pkuppler](https://forum.remote.it/u/pkuppler)\
**Post date:** [October 9, 2024, 9:25pm UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203/4 "2024-10-09T21:25:21Z")

</div>

This is not any logfile, this the output in the terminal.  
The remoteit Desktop application is installed in /opt/Remote.it/remoteit by apt.  
The current working directory is the home directory of my user.  
I start it from the command line to see the output. When I start it normally I see nothing and there is also no log file written.  
This is not the CLI this is the Desktop Application. I installed it with this .deb file :[https://downloads.remote.it/desktop/v3.32.1/Remote.It-Installer-amd64.deb](https://downloads.remote.it/desktop/v3.32.1/Remote.It-Installer-amd64.deb)

---

<div class="post-metadata">

**Author:** ![pkuppler](https://avatars.discourse-cdn.com/v4/letter/p/ba9def/32.png) [@pkuppler](https://forum.remote.it/u/pkuppler)\
**Post date:** [October 9, 2024, 9:37pm UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203/5 "2024-10-09T21:37:09Z")

</div>

When I run it as root with

```auto
remoteit --no-sandbox

```

and first execute

```auto
xhost si:localuser:root

```

it finally works, but I shouldn’t need to run it as root.  
There are just some permissions missing but I don’t know which.

---

<div class="post-metadata">

**Author:** ![pkuppler](https://avatars.discourse-cdn.com/v4/letter/p/ba9def/32.png) [@pkuppler](https://forum.remote.it/u/pkuppler)\
**Post date:** [October 9, 2024, 10:02pm UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203/6 "2024-10-09T22:02:42Z")

</div>

I tried to reinstall it again and noticed the following error message from apt:

```auto
N: Download is performed unsandboxed as root as file '(Path removed)/Remote.It-Installer-amd64.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

```

So I moved the file to /tmp and changed the owner to \_apt and the install finishes without errors, but I still get the same error:

```auto
[139187:1010/000058.712061:FATAL:credentials.cc(127)] Check failed: . : Permission denied (13)
Trace/breakpoint trap (core dumped)

```

The core dump is at `/var/crash/_opt_Remote.It_remoteit.1001.crash`

---

<div class="post-metadata">

**Author:** ![bstrech](https://yyz2.discourse-cdn.com/flex030/user_avatar/forum.remote.it/bstrech/32/266_2.png) [@bstrech](https://forum.remote.it/u/bstrech)\
**Post date:** [October 9, 2024, 10:42pm UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203/7 "2024-10-09T22:42:43Z")

</div>

The remote.it team is looking into this. What version of Ubuntu were you on previous to your upgrade of Ubuntu to 24.04?

---

<div class="post-metadata">

**Author:** ![pkuppler](https://avatars.discourse-cdn.com/v4/letter/p/ba9def/32.png) [@pkuppler](https://forum.remote.it/u/pkuppler)\
**Post date:** [October 9, 2024, 10:45pm UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203/8 "2024-10-09T22:45:38Z")

</div>

I finally figured if I run it with `--no-sandbox` it works even as the normal user.  
My previous Ubuntu version was Ubuntu 22.04  
It could be possible that I had `--no-sandbox` in the .desktop file previously and it got overridden by an update

---

<div class="post-metadata">

**Author:** ![mycal](https://avatars.discourse-cdn.com/v4/letter/m/ebca7d/32.png) [@mycal](https://forum.remote.it/u/mycal)\
**Post date:** [October 10, 2024, 12:59am UTC](https://forum.remote.it/t/ubuntu-24-04-desktop-application-not-working/1203/9 "2024-10-10T00:59:42Z")

</div>

> [@pkuppler](#):
>
> `ROR:gl_display`

Good to know thanks for the update.
