remote.it Community Forum

Remote Desktop 2.4.7 fails to set peer-to-peer connection

Remote Desktop 2.4.7 on Win 10 cannot set a peer-to-peer connection to any Raspberry Pi that is behind AT&T hotspot. Is it normal?

No problem with the remotes that are connected to the Internet by any other means. The Raspberry Pi in question is actually online and can be connected via remote.it web site; however, the Remote Desktop returns error 21 every time.

Is there any way to fix that behavior?

Hi Alex,

If a proxy connection works at the same location (that is, launching a connection from the remote.it web site), then there is a possibility that the combination of your client and target networks may not work with P2P connections. What type of internet connection do you have at your client side?

Hi Gary,
It is Verizon FiOS. I had no trouble even with double-NATting on FiOS but AT&T wireless has always been a problem. If a log can help, here it is for one remote and SSH service:

Connection started
Connectd built Apr 20 2019 at 16:38:16 Now Starting Up
Version 4.6 - ©2019 remot3.it, Inc. All Rights Reserved
Built with NATPMP BCASTER MALLOC_POOL RESOLVE BIGBUF pool=524288
WIN32 Version
restrict address = 0.0.0.0
setting web config port to dest_server_port 80
primary local ip = 192.168.1.20
alloc pool
Using server on port 5959
Using device uid = 00:00:00:00:00:00:00:00
Using Server Channel Port 5980
User alex @ skjeitelecom. com connecting to 80:00:00:00:01:03:93:2a
primary local ip = 192.168.1.20
local IP address found 192.168.1.20
initialize proxy client target 127.0.0.1 port 80
generate our own UID= f2:89:92:33:28:25:f7:88
Attach to remot3.it Service…
Command Processor now active.
!!status - bound to UDP port 33029
49385> req auth remote.it id alex @skjeitelecom. com
49385> Status redirect to 52.88.4.160:5962

49385> req auth remote.it id alex @ skjeitelecom. com
49386> NAT type selected at 3 with natmap 2

!!status - server connection changed to state 4 - time 1 <49386>
!!status - Connected to server is 52.88.4.160:5962
!!status - server connection changed to state 5 - time 1 <49387>
!!status - Connected to server is 52.88.4.160:5962
!!request to connect from remot3.it ID or device owned by alex @skjeitelecom .com <49389>

Apparently the NAT currently used by AT&T has this issue. There’s not much we can do about it.

It’s a pity. Because of that, I have to manually copy/paste SSH command every time I need to connect to any device that is behind the hotspot. When you have to work with more than 10 devices like that, it becomes a drag…

Do you know, if it is at least possible to get a list of ports and proxies for all active units on my “Devices” page? I remember that there was a couple of scripts suggested on the old forum, but I could not find them anymore…