Connecting to a Debian instance on AWS

Hello RemoteIt! Firstly, let me say you have a great product. I have been able to easily connect a couple of RaspberryPi prototypes to the internet rather easily. However, moving from RaspberryPi to a more professional platform, I encountered some difficulties. I chose to go with AWS (Amazon Web Services) as my platform, specifically Lightsail - their getting-started service which can easily be upgraded to their scalable paid services. I launched a Debian virtual machine and installed a handful of programs, including RemoteIt, like I normally would on a RaspberryPi, through AWS’s web-based SSH terminal. It was until I tried to access these programs through RemoteIt that I get errors, all similar regarding security - certificate keys (that allow for the ‘s’ in ‘https’). Does anyone have experience with setting-up RemoteIt on an AWS instance of Linux, specifically regarding the certificate keys? Do I put the key somewhere in RemoteIt? Your help is greatly appreciated. Thank you.

Hi Kristofer,

I’m not sure about the details of what you’re doing. If you are using the web portal at or you may get certificate warnings when trying to connect to https servers. You can avoid this by installing and running the Desktop application instead.

The Desktop defaults to “Named Connections/https certificate mode” as seen on the settings page.

To install certificates on your AWS Debian box, you could run:

sudo apt update
sudo apt install ca-certificates

Although I’m guessing that if you set up a secure web server, those are already there.

Let me know if this solves your problem or you still need something. If you are having errors making connections, the more details you provide, the easier it is to help you.


Gary W.

Regarding SSH to AWS EC2 instances, you should use the same PEM key that you use with AWS connection. You may have to edit the SSH command line to use:

ssh -i <pem key>

instead of

ssh -l <username>

Hello Gary! Thank you for your reply.

I was using RemoteIt Desktop. The certificates where indeed automatically created when I created the AWS Lightsail and it is clearly downloadable (refer to image).

With your advice, I was able to get an SSH connection to my AWS Lightsail. Forgive my ignorance of the SSH command. The command that worked for me in Windows10 Terminal was: ssh username@ipaddress -i localpathtodefaultkey.pem. The command the worked for me in RemoteIt Desktop was: start wt ssh -p 33000 -i localpathtodefaultkey.pem.


Great, thanks for the update.