Coonectd dependancy job failure

Hi, using add device from web portal, cannot install it. tried purging remoteit and connectd installation several times.

pi@player:/usr/bin/remoteit$ sudo R3_REGISTRATION_CODE=“************************” sh -c “$(curl -L”
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 8332 100 8332 0 0 33348 0 --:–:-- --:–:-- --:–:-- 33328
licensekey: 75A42FF0-AD30-53C2-B977-9532F32436F4
Creating registration file

  • Distribution: Raspbian

  • OS: Raspbian

  • Installing the remoteit Agent package for armhf

command: curl --output /tmp/remoteit.deb
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 91596 100 91596 0 0 365k 0 --:–:-- --:–:-- --:–:-- 365k
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘remoteit’ instead of ‘/tmp/remoteit.deb’
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/91.6 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 /tmp/remoteit.deb remoteit armhf 4.14.1 [91.6 kB]
Selecting previously unselected package remoteit.
(Reading database … 40280 files and directories currently installed.)
Preparing to unpack /tmp/remoteit.deb …
Unpacking remoteit (4.14.1) …
Setting up remoteit (4.14.1) …
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/connectd.service.
A dependency job for connectd.service failed. See ‘journalctl -xe’ for details.

Most likely, your rc-local.service is failing. Remote.It Device Package has 3 systemd service files which depend on rc-local.service. Here’s how to override that:

copy the following files from /usr/lib/systemd/system to /etc/systemd/system:

  • remoteit@.service
  • connectd.service
  • schannel.service

In the copied files in /etc/systemd/system, edit them to remove the dependency on rc-local.service as shown:



After rebooting, your Remote.It systemd services will no longer depend on rc-local.service and should start up OK. If you have any further issues please send an e-mail to for quickest response.



that worked, thank you for your help.

Glad to hear it, thanks for the update.

This is now documented at