How to make a connection relay to avoid firewall port forwarding

I’m not sure I named this topic correctly. I read about someone doing this with the RemoteIt software when it was called Weaved. Here is the link where I found the description: Accessing the classic from anywhere without port forwarding

What I want to do is access my Midnite Classic charge controllers when travelling. Midnite solar makes a Local Status App that uses Adobe Air. I run this on my laptop to connect to the charge controllers when on my local network.

I have RemoteIt installed on a RPi 400 that remains online all the time even when I’m away. I can access the RPi desktop with VNC as well as SSH. However, I can’t figure out how to set up the relay as described in the above link to access the charge controllers using my Local Status app on my laptop when I’m traveling.

The Local Status app is set up to run on IP port number 502. Both charge controllers have fixed IP address of &

I am running the RemoteIt desktop app on my Mac laptop, version 3.27.4.

Is this possible? If so, can you explain how?

Thank you in advance.

Hi Chris,

It should be very simple to do since you already have ssh and vnc working to your raspberry pi.

  1. From your RemoteIt Desktop select your Raspberry Pi device.
  2. Click the + just above the list of services on your device.
  3. I’m not sure what type of service adobe air is but let’s start with selecting TCP
  4. Enter the ip address (, port (502), and change the name to something like Classic1.
  5. Save and when the service comes online click on “Connect”
    That will start a full connection from your local Desktop to the Raspberry Pi and then to the ip address and port of the service. It should then show you a local endpoint (dns name and local port) to use to connect (ex: <devicename> When you go to connect to the classic app use the <devicename> and the local endpoint port number (ex: 33005) for the connection.

It sounds like you have 2 classics so duplicate these steps to add another service called classic2.

@robo Thank you for that explanation. I had tried those steps before with no success. I finally figured out that I needed to copy the two parts of the URL generated by RemoteIt separately and paste them each into their respective slots on the Midnite Local App. That got it to work for the first one.

I then did the same for the 2nd Classic, but it remains in the greyed out offline state. Could this be that since I’m on a free account that I can only have one TCP connection for a device at a time?

Finally, my RPi forever shows its status as “Offline” but I can still access the services. Do you know why that is? I have used the restore device option a number of times with no change.

I’m including a screen shot of the desktop app

@cjbamenda the device offline with the services online shouldn’t happen. They should all be offine. You should also not need to do a restore. The restore code should only be used if you accidentally wiped out your raspberry pi and you are replacing it with a new raspberry pi for example.

There are a couple of things that affect your online/offline status for devices and services.

  1. Make sure that all your services on your raspberry pi are started and running. There should be a service running called schannel and a daemon called connectd for your device and each service. In your case you should have 1 schannel daemons running and 5 connectd daemons running (1 for device, and 4 for your services).
  2. If you IP changes a lot then that could cause some issues. For example your raspberry pi is swapping between networks and getting a different ip address for each network. That could cause our system to detect it as a problem and possibly flag it as offline (our support team will look into this).
  3. The service is not marked as “Enabled”. You have to go into the Service Configuration section of the service that is offline and if the “Enabled” checkmark is not there then enable it and save.

If you can access your raspberry pi via ssh you might want to reboot it. It should come back online after that within 5 mins.

If after reviewing all of this it is still offline and not working then open a support issue and provide us with the email of the RemoteIt account and the Device Id which you can get from selecting the name of your device at the top of the screenshot you provided. We can investigate more with that info.

@robo, Thank you again for your explanations. For some inexplicable reason, the RPi now shows as being online and all the services are active. I did not restart the device. Strangely, this is in the midst of a major internet interruption all along the West African nations with 4 submarine fiber trunk cables having been lost at one time! Go figure.

Thank you again.