How can i stop changing http connection to https while running a sevrice


I trying to reach to a HTTP connection via but when when connection is extablished it changes to https how do i keep it http? will automatically wrap an HTTP connection to HTTPS to add extra security. This should still work for your connection. Can you please explain what is the service on HTTP and why you need to keep it as HTTP?

Hi @bstrech,

I’m running a app which uses http connect to access internal APIs and when i connect via remote since it changes to https the app cannot reach the internal APIs

ex: my app is running in should reach but it changes to while running via and API won’t respond

Where are you getting the port 7077?
Can you please take and post a screenshot of the service configuration, connection configuration and the connection url?
Please make sure to hide personally identifiable information such as email address and external IP address if shown in any screenshot.

This is the API service
2023-08-03 10_58_40-Window

the error i get because of connection chaange to HTTPS

Access to XMLHttpRequest at '***/login' from origin '' has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

POST****/login net::ERR_FAILED

I’m not able to attach one more screeshot

the service URL for UI is

When you connect, you should be given a URL from the connection that looks like a DNS name. Use this instead of the address for the connection. This doesn’t have anything to do with the change to SSL connection of HTTPS over HTTP.

Click here for poorly written webapps that hardcode their http/https This will turn off https security for http targets.

1 Like