"Connection Error: Can't resolve host" - but the connection works?

I am establishing several connections (HTTP & HTTPS) to an agent running on a remote asset using the Remote.IT desktop app. When I start the connection, I get the error:
“Connection Error: Can’t resolve host”

However, the connection still works. I’ve tried with both P2P and Proxy.

The service connection is local the the system the agent is running on. So for this Service, I’ve tried the Service URL with both “localhost” or the local IP address of the http server running on the system. Screenshot below.

I want to ensure I am not doing anything “wrong” or is something to be concerned about. Also the connection error is a little annoying :wink:

Thank you for the report. We are working on a fix.

Is it possible your system is blocking resolution to

can you ping test.at.remote.it?

if this does not work, then either DNS provider or system is blocking the “named connection” feature on the remote desktop.

You can turn this off if you like

Turning off “Named connections” in the settings does not resolve the connection error message for HTTPS connections (my HTTP connection no longer get this error).

I assume you meant a ping test on my local machine? Pinging remote.it resolved fine.

The connection is working so it’s not as if this is an issue, but seeing the error made me think there was something else wrong.

No not pinging remote.it, that is going to work since it does not resolve to localhost. Ping test.at.remote.it

It likely does not resolve

I am not sure what your getting for a HTTPS url, but if it has a name in it (not and its not a public URL then thats your problem.

What is your ISP?

Hi Mike -
Sorry for the question, but are you saying that test.at.remote.it should resolve to the local RemoteIT server / service hosted on my local system? Or should my ping request resolve a hostname that points to an RemoteIT resource externally? I am just trying to understand how this relates to your question about my ISP.

When I am at the office (where I currently am), I am at a workshare. I do not know who they use as an ISP but I am subject to their business network (the ISP identifies as The Cambridge Incubator LLC which is just the workshare’s legal name).

When I ping test.at.remote.it while at work, I get:

Ping request could not find host test.at.remote.it. Please check the name and try again.

If I ping while tethered to my mobile phone (T-Mobile network), I get:

Pinging test.at.remote.it [64:ff9b::7f00:1] with 32 bytes of data:
Request timed out.

Here is of my configuration of my HTTPS service. The screenshots were taken while connected via my tethered mobile connection. The same “Connection Error” is the same regardless if I am using my tethered connection or my workplace network:

Name connections setting is also disabled.

In either case, the connections actually do work properly, but as mentioned above I’m not sure if the Connection Error is a cause for concern, or indicates some sub-optimal configuration on my end.

Hi Mike - Just an update, making the connection from home (via my home ISP - Verizon) seems to avoid this Connection Error message. So it appears to be related to where I connect from.

So it looks like your provider on the problem network is blocking DNS resolution to localhost or giving you a bogus address, it should resolve to The named connection feature of remote.it relies on that. I have no way to duplicate that here since I do not have the tmobile hotspot.

If you turn named connections off does it work?

Probably the automatic checking is not working properly, it should check to see if the names resolve correctly and fallback to non named connections.

If you use instead of the name does it work on your connections?

Also for a test you could try using google dns (manually) on your machine when on those ISP’s.

In anycase if the connections work with the and named connections off let me know, if there is some other issue I do not understand.