I get a connection error "remote.it connected, but there is no service running on the remote machine.”

I started a connection and I am getting an error: " remote.it connected, but there is no service running on the remote machine.” What is happening and how do I fix it?

In Remote.It, “online” means that the Remote.It package is running and is contacting the Remote.It presence servers, but is not a confirmation of the service running or listening on the configured port.

According to the error message, the daemon was able to establish a connection, but the service on the device either isn’t running or it is not running on the configured port.

Double check that your service is still running and listening on the port you have configured in app.remote.it OR the Remote.It Desktop application.

If you are the owner or manager of the device, you can confirm the configured port by clicking on the Service and then “Service Configuration”. Make sure that the port is correct. For example, NodeRed is typically port 1880, but may be different if you changed your configuration in the setup of the server. If it is incorrect, update it and then try the connection again.
If it still fails, you should get access to the device on the LAN or direct access on the device to confirm that the service is running and listening.
You can run the following command. Replace with the port from the Service Configuration:
For Windows, open a command prompt as Administrator

netstat -ano | findstr <Port>

For Linux or Mac, open a terminal window

sudo netstat -ano | grep <Port>

or if you do not have netstat, you can try:

sudo lsof -i : <Port> -S

If both of the above result in “Command not found”, you will need to install netstat or lsof.
If you find that nothing is listening, then you will need to troubleshoot that. It may be that the service isn’t running or is listening on a different port. Make sure that the service is running and that you can connect on the port locally, then make any adjustments in the Remote.It service configuration as needed.

If you do not own or manage the device, you will need to contact an owner or manager of the device to verify the settings and that the service/server is running and listening on the port.


So far, Remote.it has everything of a great service, I like the interface.

However, I have this issue which I can’t solve, but maybe I did not get properly the logic of Remote.it

My problem: I want to access remotely my Synology server ay my home using sftp, but my home Internet is through Starlink, so no public adress.

I installed the remote.it app on my synology => works fine
My local ssh port is 7322 => works fine
I downloaded the remote.it app on my mac on same local network because I understand one must do this in order to have an open permanent connexion; then created a ssh service which gave me an endpoint.

However, this endpoint is not accessible from outside… “cannot connect to the port” Then “there is no service running on the machine”…

What have I done wrong ? It seems I can access it from my local machine, but not from outside ?

Many thx and congrat for this service

Usually when you are getting the “no service running on the machine” error is because you installed the target app on your synology but it is not pointed to the correct place. Synology usually has SSH on port 22, so your config on the synology should point to, if its not you would get this error.

My synology config looks like this for SSH/SFTP (they are the same service):

Thank you but no, that is not the issue. My internal port is 7322 and I have done this.

I realize my endpoint is only local; so when I try to access it from outside it says “Connection refused”

How can I have a permanent ssh endpoint visible from outside ?


Remote.It doesn’t provide a public endpoint which is visible from the outside. If you need multiple people to have access, you can share the service with them.