OpenVPN - Starlink - Synology NAS

Hi there,
I’m trying to access network resources over Starlink, but because it is CGNAT port forwarding does not work, this is a common issue and it looks like has a solution for this.

I am running a 3D printing business, so need access to my internal IP addresses to control printers etc… I had been doing this until we moved and needed startlink.

I have almost working, but never seem to quite get there, so I hope to get some help here and hope this post might help others. (If you can think of a better way to do this let me know)
I do get a connection establish between and the VPN, and I can see a connection on the NAS VPN also, but once OpenVPN connects, there is no internet connection on my PC or access to the Synology network resources. This is the problem I’m trying to resolve.
I know it can work, because I had it working once… everything worked just fine, but that was it, I have not got it working again. Why?

I have:

  • Registered a user (and paid for a professional license)
  • Installed app on my synology nas
  • setup a OpenVPN connection on
    -configured openVPN on my PC with the connection details (Tested both peer to peer and proxi, with same result)

Any ideas?

@nz_andy I believe we can make something work for you. We have been successful in helping a number of Starlink customers. I will DM you to get you going.