Starlink port problem

Hi, I’ll start by saying that I know very little about networking.

I’ve been, on my DSL connection, for a long time been accessing WinTV and Plex to access live TV and media while I travel. On my previous setup, I’ve just opened up two ports on my router and it all worked well. Now I have Starlink. That doesn’t let me do that. I now have a Vigor router, which the starlink feeds through an ethernet connection. Searching for an answer I found, on the website:

"## Replace port forwarding on Starlink

How to port forward easily? is THE tool for privately gaining access to your devices and network over any internet connection. The platform brings all the ports of your devices to your desktop. Set up your connection 1 time and access them wherever you or your device is online. Do all this with no open ports that could be scanned by potential threats.

What kind of services can I add?

… Most services that run over a TCP or UDP port can be accessed quickly and securely with"

This seems to the answer, so I’ve registered and downloaded the Windows app; and that’s where i get completely stuck.

When I add my PC as a device and try to add a TCP service (which is what the port was set to on my previous setup) I just get a message saying “No service found running on port and host address”. It runs fine locally however, using that port.

Where am I going wrong?

I’m also a Starlink user and I do know networking pretty well and the service worked for me.

The thing to know first is that the device your are exposing must be registered with and then a service is registered as well (like TCP, HTTP/s on some port) and then you need a client of some sort ( mobile app or desktop app) to start the connection to the “device” that is exposed.

In my case I have a Web server that is set up with the Blue Iris camera software to share video feeds. Blue Iris runs on Windows. This particular Blue Iris Web server runs on port 81. So with deskop on the Windows machine I register the Windows machine where Blue Iris runs as a device and search for the service on port 81 and register it (not as TCP but as HTTP or HTTPS depending on how Blue Iris is configured).

Then with a mobile app I log into the same account and see the device and HTTP service whereby I can connect to it and launch a web page (or configure the Blue Iris app) via a proxy URL that is provided by

I could not get peer-to-peer to work on the mobile device but proxy worked fine.

1 Like

Thank you for your inquiry. What is the type of service you would like to connect? Can you check that in fields I have pointed out in the image that it is set correctly?
If you are still having issues we can work with you directly at
We can loop back around to make sure the documentation is clear.

Thank you for your insight. It is true that sometimes a peer to peer connection will not work on your mobile carrier. This has to do with the carrier itself. If you are using the desktop application, you can set your routing to “Peer to Peer with Proxy Failover” which will attempt Peer to Peer first and then go to Proxy. I am guessing you already figured that out.

The recent 3.11.5 release of the Desktop application includes improved messaging when a P2P failure occurs. “Peer to peer with proxy failover” is the default setting for connections in Remote.It Desktop, but if you find that a given connection consistently fails P2P, setting the routing to “proxy only” will probably save a few seconds when you make the connection.