Added services "offline"

For context, I had a prior install on a Raspberry Pi which I managed to hose up someone, so I removed and reinstalled Remoteit and used a new Claim Code. This successfully added the SSH service to the Pi, and it worked as expected.

However, I have tried to add other services I was using before, such as access to a Pihole Web GUI and my home router’s web admin page. Both add but show a status of “offline.” On my prior install, I had all these working before I “broke” things and reinstalled.

What can I do to restore my prior function?

Upon running the steps in Checking that everything is running properly (remoteit package) –, I do not have a line for “schannel.”

When I run a status on schannel, I get:

● schannel.service - Remote tcp command service
   Loaded: loaded (/usr/lib/systemd/system/schannel.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Wed 2022-07-13 10:39:45 CDT; 5s ago
  Process: 21623 ExecStart=/usr/share/remoteit/schannel -f /usr/share/remoteit/schannel.conf (code=exited, status=1/FAILURE)
 Main PID: 21623 (code=exited, status=1/FAILURE)

Jul 13 10:39:45 raspberrypi systemd[1]: schannel.service: Failed with result 'exit-code'.

Thanks in advance.

Let’s start with what is and isn’t installed.

sudo dpkg -s remoteit
sudo dpkg -s connectd
which remoteit

What do those give you?

ps ax | grep connectd
ps ax | grep schannel
sudo netstat -lpn | grep 5980

What’s running?



Thanks for the response. Here’s the feedback I get from each of those commands (I left out the Descriptions):

sudo dpkg -s remoteit

Package: remoteit
Status: install ok installed
Priority: optional
Section: non-free/net
Maintainer: Benoit Menendez <>
Architecture: armhf
Version: 4.14.1
Depends: curl, jq

sudo dpkg -s connectd

Package: connectd
Status: install ok installed
Priority: optional
Section: non-free/net
Maintainer: Gary Worsham <>
Architecture: armhf
Version: 2.3.17
Depends: libc6 (>= 2.1), mawk (>= 1.0), grep (>= 2.1.6), curl (>= 7.21.0), cron (>= 3.0)
 /etc/connectd/schannel.conf f9d834fb7d977ec238f68819098623ec
 /etc/connectd/bulk_identification_code.txt 8665e33e60b952753676c66efeeafc3c
 /etc/connectd/hardware_id.txt 3707a13250ade0ea5c193dbbb76e7155
 /etc/connectd/registration_key.txt 3707a13250ade0ea5c193dbbb76e7155

which remoteit

ps ax | grep connectd

 1377 ?        Ss     0:14 /usr/share/remoteit/connectd -e bWF4X2RlcHRoIDM1CmFwcGxpY2F0aW9uX3R5cGUgMjgKcHJveHlfZGVzdF9pcCAxMjcuMC4wLjEKbWFudWZhY3R1cmVfaWQgMzQzMDQKcGxhdGZvcm1fdmVyc2lvbiAxMDcyCnByb3h5X2Rlc3RfcG9ydCAyMgpVSUQgODA6MDA6MDA6MDA6MDE6MjI6RjI6RTcKc2VjcmV0IERBRTIyRTY0REVENzE2RTUyQzc3M0U1MzZCNUVGQkNFMEYyQjdDMTgKIwo=
 1381 ?        Ss     0:10 /usr/share/remoteit/connectd -e bWF4X2RlcHRoIDM1CmFwcGxpY2F0aW9uX3R5cGUgMzUKcHJveHlfZGVzdF9pcCAxMjcuMC4wLjEKbWFudWZhY3R1cmVfaWQgMzQzMDQKcGxhdGZvcm1fdmVyc2lvbiAxMDcyCnByb3h5X2Rlc3RfcG9ydCA2NTUzNQphcHBsaWNhdGlvbl90eXBlX292ZXJsb2FkIDQwClVJRCA4MDowMDowMDowMDowMToyMjpGMjpFNgpzZWNyZXQgNzc2QjQyMkM0QTdERDdDMzhCQTA4QUYwMUJCOUQxMkFFMjQwMzdFMwojCg==
 8365 pts/0    S+     0:00 grep --color=auto connectd

ps ax | grep schannel
8386 pts/0 S+ 0:00 grep --color=auto schannel

sudo netstat -lpn | grep 5980
udp 0 0* 344/remoteit

Wow, it looks like you have the remoteit CLI, remoteit Device Package and connectd all installed.

This probably won’t work too well. Note, you probably can’t easily recover without having the device local to you.

Here’s what I’d try:

sudo remoteit agent uninstall
sudo dpkg --purge remoteit
sudo dpkg --purge connectd

Then start over here:

The instructions you gave me allowed some progress. After running those commands and reinstalling, I got the default SSH service to connect back to my Pi, which worked as it has. I was also able to add another SSH service to my router, tested and worked. However, the 2 HTTP services I added would not allow connection.

The Pihole Web Admin service I created resulted in a ERR_NAME_NOT_RESOLVED (target IP on my LAN is The service I created to access my router’s admin web interface gave “undefined ’s server IP address could not be found” (target IP

I’ve had both these HTTP services working in the past, but I don’t know what changed and I’ve tried so many things to fix them, I can’t be sure where the problem is.

You might want to experiment with the Browser URL


and target host name settings of the connection.


Before, when I had it working, the only alteration from default I recall making was adding “/admin” to the end of the BROWSER URL setting for the Pihole admin login.

Now, when I go with the default Browser URL (without the /admin), I get (from a remote location to my host):

If I add /admin and launch, I get " undefined ’s server IP address could not be found." in my web browser (MS Edge in this case, Chrome says “DNS_PROBE_FINISHED_NXDOMAIN”).

I get the same response regarding “undefined” when I try to use to access my router admin web page.

As for experimenting with target host name settings, I don’t really even know what to try here. I’m using LAN IP addresses, not host names, for accessing these devices as I did before when it worked. I did try using a couple of hostnames that should be valid but I don’t regularly use, to no avail.

Another wrinkle in this is that I can access the HTTP pages from my iPhone client as well as the web client, using the what seems to be the same settings as the desktop client. It’s like the desktop client is formatting the URL in a different way.

EDIT: Another update. I can now get into my router’s admin webpage after I went to Setup/Connection Defaults/Target Host Name and entered (the same address that was already in Setup/Service Host Address). I tried the same strategy on the Pihole admin page and no change, however if I remove the “/admin” from the Browser URL entry, it successfully loads the “did you mean to load the admin page?” website.

So something about that trailing /admin is the trigger on the desktop client, even though it works fine in the web client.

It appears I’ve found a solution.

In short, I had to add a trailing “/” to “/admin” where I hadn’t had to do that in the past. I don’t know if it’s an update to or the fact that I upgraded my RPi OS from Stretch to Buster about a week ago, or if it’s completely unrelated. So now the Browser URL field reads http://[host]:[port]/admin/.

In detail, I found that adding /admin/ to the “Browser URL” field instead of just adding “/admin” made the problems go away. I also removed the information I had entered into “Target Host Name” under Connect/Options and “Target Host Name” under Setup, and reverted “Service Host Address” to So pretty much everything at the default HTTP service values now.

I’ll try to set up PiHole here and see what happens.