AWS EC2 RDP erratic behaviour

I have an AWS EC2 running Windows Server 16.

For several years I have been accessing the running instance of this EC2 via RDP on my Windows 10 desktop - using the Windows shortcut created using “Download remote desktop file” as described in:

This connection method has worked reliably for all this time.


On this EC2 I have recently installed and set up a RDP server service.

On my Windows 10 desktop PC I have installed and set it up as an initiator.

When I launch on my Windows 10 desktop PC I can see the AWS EC2 RDP service.

When I try to launch this RDP service it is totally erratic - it sometimes works but, more commonly it fails with “Please wait for the Local Session Manager”.

However the Windows shortcut connection always works.

Any suggestions appreciated…

In a last blind attempt, I upgraded my EC2 from Windows Server 2016 to Windows Server 2022.

This seems to have fixed it - and I am getting really impressed with

1 Like

Thanks for the update Jack!