Trying to enable macos device saying "this is not your system"

I’m trying to enable agent on my imac 24" m1 setup running macos ventura 13.4.

I am signed in with the local account that is the administrator for the setup.

After downloading and installing the agent and selecting + / add a device under add this system it shows name of the system which is grayed out with additional message “this is not your system”.

If i select + / add a device | add a device | mac | or add this device (<system name>) it generates error popup stating “You don’t have access to that device. (90:00:00:00:00:00:86:FB)”.

Any insights as to what i’m overlooking in order to get enabled on this system so i can open up the screen sharing / remote management access over vnc protocols tcp/5900 port?

Did you previously install another product such as the Remote.It CLI or use this computer to setup Insomnia or another development environment that uses the Remote.It API?

1 Like

None of those.

I may have tried agent install on this iMac a while ago though if that was the case i don’t see any remnants of it in the Applications folder, before doing install today, and nothing jumping out in settings | general | login items view or /Library/LaunchAgents and /Library/LaunchDaemons paths.

Is there somewhere else i should look for left overs from some prior agent install that could be causing me to be blocked from enabling a connection for this device in the agent settings?

Yes, there likely is a remnant of the device package if it wasn’t purged correctly. From our backend when you previously tried to install the device package, it was never claimed so the device doesn’t belong to anyone.

Please quit the desktop app, then delete the file /etc/remoteit/config.json

sudo rm /etc/remoteit/config.json
sudo remoteit agent stop

Once you have done that, then you can restart the Desktop Application. It should restart the application and the agent, then you can register your device in the app. Please note, you only need to register your Mac if you intend to allow connections to it. Regardless, you should remove that one file.

1 Like

Thanks for the follow up, that fixed things up.

Is it expected that an uninstall of agent on macos will leave behind the /etc/remoteit/config.json remnant that can lead to this experience in future effort to enable agent?

The ‘sudo remoteit agent stop’ call never completed so i ctrl+c terminated and retried with same result. After that i just proceeded with started agent and things were resolved. Is that command expected to return and any known issues why it wouldn’t have?

I am glad it is working.

I cannot really answer why the uninstall didn’t complete without knowing the command you ran to uninstall. It should have been a “sudo apt purge remoteit” command which should clean up the files. However, we do not have a Mac specific device package install, so it is hard to say if it failed to complete install as well.

The sudo remoteit agent stop command may take a while to complete. I was having you run it to make sure that the remoteit CLI which was running underneath stopped and reloaded with the Desktop restart so that if it was holding that config in memory it would be released. However, Desktop did the right thing so you are good to go.

1 Like

Thanks for clarifications and additional details. Does “sudo apt list/purge remoteit” type command work on macos or does one have to execute a [home]brew equivalent?

Any pointers you can provide on what i’d have to do to enable a agent/device setup to be reached by multiple users not just the one used to enable it?

Mac OS doesn’t have apt installed by default and you are right typically you use homebrew. Since I do not know how you installed or uninstalled the original device package, I cannot say for sure. Sorry, I forgot when I replied. The apt command is for typical Linux systems. However, since you got this working, it is not an issue.
As far as giving access to other users, you can refer to this article. Device and Service Sharing Overview - Orgs and Direct Shares

1 Like

Hi @bstrech, the prior experiment i did with agent install on macos device as was the case with current one was installed using the “” download that you drag onto applications folder. For removal i would have dragged from applications folder to trash or selected that option from the context menu.

Thanks for pointer to documentation on granting other users access to a reverse proxy’d service exposure point. Was very intuitive and easy once i realized i just had to scroll further down the device | service view to find the access section for controlling that. Really appreciated how it let me enable a guest user service access based on email of user that had yet to create a identity.

1 Like