Authentication error whenever I try and log into the app

I recently downloaded the desktop application (I’m on macOS Catalina) and every time I try and log into it I get an “Authentication error.”
I’m still not sure where the issue is coming from as I can log into the website and I can log into perfectly fine.

I’ve attached a screenshot with screenshots for further information on the issue. It’s all the images put together since as a new user I can’t add more then 1 screen shot haha.
Uploading: 16AD131E-4A9A-4AE8-90AD-A1FCCFA5922A_1_105_c.jpeg…

Things I’ve tried:

  • Uninstalling the app and reinstalling
  • Deleting the .remoteit folder in /User/.remoteit (then reinstalling again)
  • Making a new account (same error)
  • Logging in with Google (same error)
  • Using forgot password (same error)

Some more info:

  • I downloaded the X86_64 desktop application (info in screenshot above)
  • MacOS info (info in screenshot above)
  • Here is a picture of the .remoteit/log error log (info in screenshot above)

Anyways, any help would be appreciated as I would really like to use the application for some projects. Thanks in advance,

After debugging this with you it seems to be an issue with the age of the Mac and OS and the library that the App uses to make API requests. Since this is a 2012 Mac running Catalina and cannot be upgraded to more recent versions of MacOS.

You should use which will make connections that are different urls each time, but still should be reliable for you. The connection will stay alive for up to 15 minutes of inactivity on the connection or a max of 8 hours.