Setting up an Ark Server

I’m very new to this software. I followed these instructions:

I ended up with this:
I am aware that port 22222 is not default, but in Ark Server Manager, that is the port I have it set to. also when I grab a list of ports being used by Ark server manager 22222 does come up.
When I and my husband try to join via Steam server list we get a “Network Failure Message: Unable to query server info for invite”
When we try to join via Ark>Join Ark>Session Filter>Favorites we get “Joining failed: Connection timeout”

In the steam>Servers>Favorites, the server was created by copying and pasting this: “”

Another thing to note: The firewall is set to allow “Ark Server” Through.

I feel like I nearly have this set up. If someone could just point me in the right direction I’d really appreciate it.

Remote.It will assign new ports to your connections in the 33000 and up range. You should use these ports when setting up your connection via Steam. Remote.It doesn’t need specific firewall rules unless you block outbound traffic which is not done in most cases. If you are going to use Remote.It you do not need to have your “Ark Server” rules. I will need to let someone else respond to the actual Ark setup.

thanks for the reply.

I set up the connection through Steam using the 33000 port.
With the current set up I am able to see (through Steam) the name, max player count, PvE, and other settings that I customized. It’s only when I try to actually play that I see the errors: “Network Failure Message: Unable to query server info for invite” or "Joining failed: Connection timeout

I would need to see where you are seeing this error message. Are you trying to use the connection via Steam server or local Steam? Remote.It will only work when connecting directly to the server, in the case of Steam this would mean you are running the Steam server directly.

I have a spare machine I use to run servers. I recently acquired Starlink so now I have to find a way around port forwarding. Given my experience in networks, it’s likely I have something really basic wrong… some setting… idk

hopefully, these screenshots will clarify what I’m doing. if not, please let me know what you need.
steam server list, server connection settings, and settings:

*note: the TCP services I made seem to have no function (and weren’t part of the walkthrough I included in my original post.)
after clicking “Join game” and putting in the password, this screen eventually shows up:

Within the game itself, the server is visible:

Clicking “Join” and entering the password results in this:

thank you again for your time!

Ok. I see what is happening. You are using the localhost connection with the original port.
Typically, you need to use the url and port that Remote.It is supplying for the connection into your game (for example:, but since I believe Ark doesn’t allow a custom url and port for each connection, we will need to override what Remote.It does.

You will need to turn off named connections, by clicking on your avatar, then Settings and toggle off Named Conections.

For each connection for the Ark Server, we are are going to override and make a localhost address ( This will avoid overlap if you are running a local Ark server yourself on the computer you are using to remotely connect to another server.

  1. On the connection screen for each service at the site, click on Connection configuration, then Local Network Sharing.
  2. On the second screen, Enable LAN Sharing.
  3. In the Bind IP Address field put in Click Save.
  4. Back in the Connection Configuration screen, override the Local Port to match the port for the service (for instance if the service is on port 7777). Click the check box to save.
  5. Make your connection, use the provided and port.

Repeat this for all of the services you need. Then in your application once you make your connections you will use the IP address and their respective ports.

1 Like

Thank you! That ended up fixing the issue.

1 Like

Hello BStretch,
I have 2 issues with the software and I was wondering if you had any fixes or could point to the guide to look at.

  1. Settings keep resetting to default.
    This is very annoying. anytime I restart my computer, the settings for each service return to default.
  2. The connection immediately defaults to “Idle” or at least the “tunnel” is not active. I have to set the connection timeout to never, but sometimes it immediately returns to default (15min)

I have tried to reproduce the reported issues, but haven’t been successful yet.
If you can reproduce these and send in a support ticket including your Desktop Logs to, it will help us diagnose and fix the issues.
When using the Desktop Application, you can get your logs and configuration files using these instructions:

  1. Click on your avatar > Settings > Advanced > “Show support files”
  2. This will open multiple folders
  3. Zip and send all of the files.

You can try setting the defaults for the connection on the service rather than setting the connections for your computer. When you set the connection defaults on the service configuration page, that is saved into the cloud rather than on your computer. However, the port assignment can only be done on the connection setting. (You may want to update the service name to include the port number)
See this help page: Connection Settings

Hi, I ran into issue 2 again. I have the zip file but can’t seem to upload here because
“Sorry, new users can not upload attachments.” Is there another good place to upload the zip?

I sent you a PM to send in your logs to which I mentioned in my last post. This will not have the limitations of the forum for attachments.

Based on your logs I do not see an error.
To set your connection defaults please refer to this article:
Your connections should work without setting the timeout to never. When the connection is used it should automatically reconnect if it is idle. If it fails at first there may be an issue with the reconnect where it is slow to respond and may not re-establish in time.

I was able to set the default timeout to never, but this is still an issue.

Also occasionally(much more rarely), mid game, our connection will time out only to find that the service has gone idle again. Do you think this could be an ark specific problem? When you set up the connection the first time it has the yellow warning sign that no service is detected ( like on the guide that I followed. (Link at the top of our forum))

It might be an issue with the Ark Server and how it is using the connection.