remote.it Community Forum

Unable to start Beta windows application

I have downloaded remoteit-app-2.3.27.exe, installed, without error on Windows 10 pro up to date.
A connexion screen opens with a blue button “Install now”. After some seconds, this windows close and it is all …

I tryed to uninstall, reboot the PC, then re-install … same.

Sorry to hear it didn’t work. Would you be able to email support@remote.it the last ~25 lines of the log file? It might reveal what the issue is. It should be located in your user directory here:
C:\Users\<USERNAME>\AppData\Local\remoteit\logs\remoteit.combined.log

Thanks for trying the Desktop app!

Hello Jamie,

  The file is not so big, so I join the full file. The error

logfile in the same directory is empty.

King regards,

Georges

remoteit.combined.log (27.9 KB)

I recently installed remoteit on this (new) machine running Win 10, but I used remote.it-1.9.4.exe, not remoteit-app-2.3.27.exe.
It worked perfectly.

Ok Georges, I have made some change and added additional error handling. Would you be able to test another release? I really appreciate your help and feedback.

https://github.com/remoteit/desktop/releases/download/v2.4.1/remoteit-desktop-2.4.1.exe

Please remove the old software before installing this pre release version. Going forward after v2.4.0 the releases will auto-update.

Thank you!

Hi Jamie,

  We progress, I installed on another w10 machine, then login/pwd,

then install now and then message:

I join also the log file if usefull

Best regards, Georges

remoteit.combined.log (4 KB)

Thank you Georges this is helpful. We will continue to test and will get back to you soon as we can.

Ok, so I have created another build of the application to test. It has the granting of user permissions to our command line utility separated out in the installation. It should catch a failure in the permission setting and just log it instead of stopping installation. If you could test again it would be highly appreciated.

Based on the error message you received, we are speculating that the system you are on has had some changes to the basic user setup or is on a domain instead of being a standalone system. Any information you can provide about your system would also be very helpful for us to reproduce the problem.

Here is the new build to test:
https://github.com/remoteit/desktop/releases/download/v2.4.2/remoteit-desktop-2.4.2.exe

Thanks again for your help!
Best, Jamie.

Hi Georges. If you could test again, please note following procedure.


  1. Uninstall remote.it using Control Panel
  2. Please do the following before re-installing
    2-1. Stop remoteit using task manager (if running)
    2-2. Manually delete all of the following 4 folders.
    C:\Program Files\remoteit
    C:\Program Files\remoteit-desktop
    C:\ProgramData\remoteit
    C:\Users<username>\AppData\Local\remoteit\

Thanks again for your help!
Best regards, Hiroshi.

Hello Jamie,

Sorry for delai, I was a little busy,

  Find enclosed a pdf description of my installation of 2.4.2  and

a zip file with content of appdata\local\remite.it

Regards, Georges

remoteit.zip (2.22 KB)

Installation of Remote-it 2.4.2.pdf (132 KB)

Ok I think we’ve got it fixed! Thank you so much for your help. If you can - please test the v2.4.3 build. It is assigning permissions the correct way for all locales now.

https://github.com/remoteit/desktop/releases/download/v2.4.3/remoteit-desktop-2.4.3.exe

Again, your help and feedback is greatly appreciated!
Cheers, Jamie.

Hello,

Fine, that is now OK. May I place some suggestions :

  - suppress the warning message by installing that says your are

not recognized by microsoft.

  • save user/password i.e. in firefox acount

    - once connected, launch an app, (for ssh: putty, for https: the
    

default browser)

  - could be also interesting to connect with smb on a share to the

distant server, so it could be possible to open file explorer on
the PC to access files on the share (like if opn a LAN)

Thanks for all

Regards

Georges

1 Like